diff libgomp/testsuite/Makefile.am @ 111:04ced10e8804

gcc 7
author kono
date Fri, 27 Oct 2017 22:46:09 +0900
parents a06113de4d67
children 1830386684a0
line wrap: on
line diff
--- a/libgomp/testsuite/Makefile.am	Sun Aug 21 07:07:55 2011 +0900
+++ b/libgomp/testsuite/Makefile.am	Fri Oct 27 22:46:09 2017 +0900
@@ -3,7 +3,7 @@
 AUTOMAKE_OPTIONS = foreign dejagnu
 
 # May be used by various substitution variables.
-gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+gcc_version := $(shell @get_gcc_base_ver@ $(top_srcdir)/../gcc/BASE-VER)
 
 EXPECT = $(shell if test -f $(top_builddir)/../expect/expect; then \
 	   echo $(top_builddir)/../expect/expect; else echo expect; fi)
@@ -11,3 +11,17 @@
 _RUNTEST = $(shell if test -f $(top_srcdir)/../dejagnu/runtest; then \
 	     echo $(top_srcdir)/../dejagnu/runtest; else echo runtest; fi)
 RUNTEST = "$(_RUNTEST) $(AM_RUNTESTFLAGS)"
+
+
+# Instead of directly in ../testsuite/libgomp-test-support.exp.in, the
+# following variables have to be "routed through" this Makefile, for expansion
+# of the several (Makefile) variables used therein.
+libgomp-test-support.exp: libgomp-test-support.pt.exp Makefile
+	cp $< $@.tmp
+	echo >> $@.tmp \
+	  'set offload_additional_options "$(offload_additional_options)"'
+	echo >> $@.tmp \
+	  'set offload_additional_lib_paths "$(offload_additional_lib_paths)"'
+	mv $@.tmp $@
+
+all-local: libgomp-test-support.exp