diff zlib/Makefile.am @ 111:04ced10e8804

gcc 7
author kono
date Fri, 27 Oct 2017 22:46:09 +0900
parents 77e2b8dfacca
children 1830386684a0
line wrap: on
line diff
--- a/zlib/Makefile.am	Sun Aug 21 07:07:55 2011 +0900
+++ b/zlib/Makefile.am	Fri Oct 27 22:46:09 2017 +0900
@@ -5,9 +5,10 @@
 ACLOCAL_AMFLAGS = -I .. -I ../config
 
 ZLIB_SOURCES = adler32.c compress.c crc32.c crc32.h deflate.c \
-deflate.h gzio.c infback.c inffast.c inffast.h inffixed.h inflate.c \
+deflate.h gzguts.h gzread.c gzclose.c gzwrite.c gzlib.c \
+infback.c inffast.c inffast.h inffixed.h inflate.c \
 inflate.h inftrees.c inftrees.h trees.c trees.h uncompr.c zconf.h \
-zconf.in.h zlib.h zutil.c zutil.h
+zconf.h.in zlib.h zutil.c zutil.h
 
 if TARGET_LIBRARY
 noinst_LTLIBRARIES = libzgcj_convenience.la
@@ -15,7 +16,7 @@
 else
 toolexeclib_LIBRARIES = libz.a
 libz_a_SOURCES = $(ZLIB_SOURCES)
-libz_a_CFLAGS = $(AM_CFLAGS)
+libz_a_CFLAGS = $(AM_CFLAGS) $(PICFLAG)
 endif
 
 # Work around what appears to be a GNU make bug handling MAKEFLAGS