diff libstdc++-v3/testsuite/Makefile.am @ 145:1830386684a0

gcc-9.2.0
author anatofuz
date Thu, 13 Feb 2020 11:34:05 +0900
parents 84e7813d76e9
children
line wrap: on
line diff
--- a/libstdc++-v3/testsuite/Makefile.am	Thu Oct 25 07:37:49 2018 +0900
+++ b/libstdc++-v3/testsuite/Makefile.am	Thu Feb 13 11:34:05 2020 +0900
@@ -1,6 +1,6 @@
 ## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001-2018 Free Software Foundation, Inc.
+## Copyright (C) 2001-2020 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -196,9 +196,6 @@
 atomic_flags=$(ATOMIC_FLAGS)
 parallel_flags="unix/-D_GLIBCXX_PARALLEL/-fopenmp"
 
-# Runs the testsuite in profile mode.
-profile_flags = "unix/-D_GLIBCXX_PROFILE"
-
 check-debug: site.exp
 	outputdir=debug; export outputdir; \
 	if test ! -d $${outputdir}; then \
@@ -226,17 +223,8 @@
 	CXXFLAGS="-D_GLIBCXX_PARALLEL -fopenmp $(atomic_flags) $(libgomp_flags)"; export CXXFLAGS; \
 	${check_performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
 
-check-profile: site.exp
-	-@(outputdir=profile; export outputdir; \
-	if test ! -d $${outputdir}; then \
-	  mkdir $${outputdir}; \
-	fi; \
-	srcdir=`$(am__cd) $(srcdir) && pwd`; export srcdir; \
-	EXPECT=$(EXPECT); export EXPECT; \
-	$(MAKE) CXXFLAGS="$(atomic_flags) " RUNTESTFLAGS="$(RUNTESTFLAGS) conformance.exp --outdir $${outputdir} --objdir $${outputdir} --target_board=$(profile_flags)" check-DEJAGNU; )
-
 .PHONY: baseline_symbols new-abi-baseline \
-	check-abi check-compile check-performance check-parallel check-profile
+	check-abi check-compile check-performance check-parallel
 
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
@@ -245,4 +233,4 @@
 
 # To remove directories.
 clean-local:
-	rm -rf de fr debug parallel profile binaries normal* 
+	rm -rf de fr debug parallel binaries normal*