diff lto-plugin/configure.ac @ 145:1830386684a0

gcc-9.2.0
author anatofuz
date Thu, 13 Feb 2020 11:34:05 +0900
parents 04ced10e8804
children
line wrap: on
line diff
--- a/lto-plugin/configure.ac	Thu Oct 25 07:37:49 2018 +0900
+++ b/lto-plugin/configure.ac	Thu Feb 13 11:34:05 2020 +0900
@@ -1,4 +1,3 @@
-AC_PREREQ(2.64)
 AC_INIT([LTO plugin for ld], 0.1,,[lto-plugin])
 AC_CANONICAL_SYSTEM
 GCC_TOPLEV_SUBDIRS
@@ -18,8 +17,8 @@
 saved_LDFLAGS="$LDFLAGS"
 LDFLAGS="$LDFLAGS -static-libgcc"
 AC_MSG_CHECKING([for -static-libgcc])
-AC_LINK_IFELSE([
-  int main() {}], [have_static_libgcc=yes], [have_static_libgcc=no])
+AC_LINK_IFELSE([AC_LANG_SOURCE([
+  int main() {}])], [have_static_libgcc=yes], [have_static_libgcc=no])
 AC_MSG_RESULT($have_static_libgcc); 
 LDFLAGS="$saved_LDFLAGS"
 # Need -Wc to get it through libtool.