diff libssp/Makefile.am @ 131:84e7813d76e9

gcc-8.2
author mir3636
date Thu, 25 Oct 2018 07:37:49 +0900
parents 04ced10e8804
children 1830386684a0
line wrap: on
line diff
--- a/libssp/Makefile.am	Fri Oct 27 22:46:09 2017 +0900
+++ b/libssp/Makefile.am	Thu Oct 25 07:37:49 2018 +0900
@@ -1,6 +1,6 @@
 ## Makefile for the toplevel directory of the libssp library.
 ##
-## Copyright (C) 2005-2017 Free Software Foundation, Inc.
+## Copyright (C) 2005-2018 Free Software Foundation, Inc.
 ##
 
 AUTOMAKE_OPTIONS = 1.9.5 foreign
@@ -34,6 +34,7 @@
 endif
 
 AM_CFLAGS = -Wall
+AM_CFLAGS += $(XCFLAGS)
 
 toolexeclib_LTLIBRARIES = libssp.la libssp_nonshared.la
 
@@ -53,7 +54,7 @@
 
 libssp_nonshared_la_SOURCES = \
 	ssp-local.c
-libssp_nonshared_la_CFLAGS = -prefer-pic
+libssp_nonshared_la_CFLAGS = -prefer-pic $(XCFLAGS)
 libssp_nonshared_la_LIBADD = 
 libssp_nonshared_la_DEPENDENCIES = $(libssp_nonshared_la_LIBADD)
 libssp_nonshared_la_LDFLAGS = -static